
RockWorks | Borehole Operations | I-Data | Section | Model-Based
Use this program to:
- Create a new 3-dimensional solid model representing your downhole interval-sampled data (an .RwMod file)
- OR -
Read an existing .RwMod file you've already created.
- Slice this model along any path and create a 2D cross section diagram. Because the model is interpolated across the entire project, you can place the section panels anywhere you like.
The section panels can be color-coded in a variety of ways, logs can be plotted at the panel junctions, and additional layers can be appended. The completed I-data section can be displayed in RockPlot2D.
See also
I-Data Profiles for single-panel cross sections with projected logs
I-Data Projected Sections for multi-panel sections with projected logs
Hole to hole I-Data Sections for quick sections not based on a solid model
Feature Level: RockWorks Standard and higher
Menu Options
Step-by-Step Summary
Tips
- Rules & Filters: Use the buttons at the top of the window to apply filters and rules for this program. (More info)
- Spatial Filter: Filter the input data for the I-Data model based on XYZ location, filter the data to be displayed in striplogs, if activated. Note that these tools filter the data that is passed to the modeling and log-generating procedures. This is distinct from the filters that are applied once the model is completed, and described below.
- Time Filter: Filter any T-Data or Aquifer data in striplogs, if activated.
- Stratigraphic Rules: Apply stratigraphy rules for Stratigraphy data in striplogs, if activated.
- 2D Log Design
Click here to choose which data items are to be displayed in the logs, if activated via the Striplogs checkbox below, and in which order. See Using the 2D Log Designer and the Visible Item Summary.
! For Section diagrams, striplogs will be plotted vertically regardless of any non-vertical orientation.
- Section Location
Click on this button at the top of the window to draw, on a map display of your enabled boreholes, where the cross section panels are to be placed. The most recent section drawn for this project will be displayed (More info)
- Location Map
Check this box to create, along with the section, a reference map that shows the section's location. It can be embedded in or created separately from the cross-section.
Click on this tab to establish the map options. (More info.)

- Faulting
Click on this tab to enable the display of faults and to modify fault options. (Read this for more details.)
- Vertical Exaggeration
Click here to pre-define the vertical stretch you would like to apply to your diagram. By giving the program this information in advance of generating the cross-section, it can help with text and graphic sizing and placement. (More info.)
! Note that you can always change the vertical exaggeration at which the diagram is displayed, in the RockPlot2D window itself. But, by telling the program up-front how stretched it will be, you'll get better placement of the graphic components.
- Model
Click this tab to define whether you wish to use an existing solid model (from a previous use of this tool or another I-Data menu tool) or you wish to create a new solid model and set the modeling options.
! NOTE This is not trivial. Creating the solid model can take some time, depending on the resolution of the model and the detail of your data. If you already created a pleasing model for display as a fence diagram, for example, you can use the same model, which was stored on disk as an .RwMod file, for the section.
- Create New Model: If you want to create a new solid model to be represented in the section diagram, click in this radio button, and use the tabs to the right to establish the modeling settings.
- I-Data Input
- Track: Click on this item to select the track or column in the I-Data table that is to be modeled. The names displayed in the list will be pulled from the column headings.
- G-Value Filter: Activate this option to establish a data filter based on the measured values (geochemistry, etc.). Click on this tab to establish the filter parameters. (More info)
- Resample: Check this box to resample the data and click on the tab to establish the resampling options. (More info)
- Solid to be created: Click to the right to enter a name for the I-Data model. The program will append automatically the file name extension ".RwMod".
- Algorithm: Click this tab to select the modeling method to use, for interpolating your I-Data model. (More info)
- Special Options: Click on this tab to establish other model settings, such as tilting, warping, filtering above-ground, and smoothing. (More info)
- Dimensions: Click here to establish the output dimensions of the solid model. (More info)
- Use Existing Model
Click in this radio button if you wish to use an already-existing solid model of your interval data, to generate the section diagram.
Click on this tab to specify the name of the existing model.
- Solid Model: Click to the right to browse for the name of the existing existing solid model (.RwMod file) to be used for this diagram.
- Traverse Defined By...: Use this setting to tell RockWorks how you want to define the cross section location.
- Contours
Click this tab to access the panel appearance settings.
- Colored Intervals: Check this item to display G-value distribution on the section panels with color-filled intervals. Click this tab to access the color contour settings. (More info)
- Contour Lines: Check this item to include G-value contour lines on the panels. Click on this tab to access the contour settings. (More info)
- Striplogs
Check this item to include 2D logs with the I-Data section display. Click the 2D Log Design button at the top of the window to set up how you want the logs to look. Click on this tab to establish some additional striplog settings.
! NOTE: If you draw your section panel endpoints between boreholes (which is possible) AND if you request that the logs be included, the program will display the log for the closest borehole at the panel junctions.
- Use True Vertical Depth: Check this box if you have deviated holes and want them to be plotted in the section using true vertical depth rather than measured depth.
- Clip: Check this box if you want to display a subset of the log data. Click on the tab to define the elevation range to be displayed.
- Top Elevation: Enter the uppermost elevation to be displayed in the logs.
- Base Elevation: Enter the lowermost elevation to be displayed in the logs.
! Log clipping parameters are defined using elevations, not depths. (More info.)
- Save Log List: Check this to save to a text file the names of the boreholes that are included with the section diagram.
- File in which to store the Log List: Enter the name for the log list text file.
- Display List Upon Completion: Check this to display the text list in Notepad (or equivalent) after the diagram is completed.
- Annotation
Click on this tab to establish title, border, axis labels, and other perimeter settings for the section. (More info.)

- Surface Profile
Check this box to include a polyline on the section diagram that represents a user-selected elevation grid model, such as the ground surface.
Click on this tab to access the surface profile options.
- Grid Model: Browse for the name of the existing grid model (.RwGrd file) to be represented in the polyline.
- Polyline Attributes: Click this tab to establish the line settings. (More info.)

- Faults
Check this box if you want to display lines in the output diagram where the section slice intersects the fault(s) defined in the Faults program tab.
Click on this tab to set up the fault lines. (More info.)

- Infrastructure
Check this box to display buildings, pipes, or other infrastructure with your section.
Click this tab to define the infrastructure file and plot settings. (More info)

- Other 2D Files
Check this option to include existing RockWorks diagrams as layers with your I-Data section.
Click on this tab to select the existing .Rw2D files to be included. (More info)
- Peripherals
Check this option to include various peripheral annotations with your section. Options include titles, text blocks, legends, logos, and more.
Click on this tab to activate the items and establish their settings. (More info)

- Border
Check this option to include a solid line border around the entire section image.
Click on this tab to establish border settings.
- Output Options
- Save Output File: Check this to assign a name for the diagram in advance, rather than displaying it as Untitled.
- Automatic: Choose this option to have RockWorks assign the name automatically. It will use the name of the current program plus a numeric suffix, plus the ".Rw2D" file name extension.
- Manual: Choose this option to type in a name of your own for this file.
- Display Output: Check this option to have the resulting diagram displayed in RockPlot2D once it is created.
- Access the RockWorks Borehole Manager program tab.
- Enter/import your data into the Borehole Manager. This tool specifically reads location, orientation (if any), and I-Data.
- Select the Borehole Operations | I-Data | Section | Model-Based menu option.
- Enter the requested program settings, described above.
- If you are including logs with the diagram, be sure to click on the 2D Log Designer tab at the top of the window to establish how you want the logs to look.
- If Traverse Defined By is set to Interactive Map, click on the Section Location tab at the top of the window to draw or import the section location.
- Click the Continue button to proceed.
If you've selected Use Existing Model, the program will load the information from the existing model (.RwMod file), and will proceed to diagram generation.
If you've selected Create New Model, the program will scan the project database and extract the XYZ points for all of the downhole measurements for the selected I-Data track. (For I-Data, the elevations will represent interval midpoints.) It will apply any source data filters you have requested.
The program will use the selected algorithm to create a solid model of the downhole interval data representing geochemistry, geotechnical measurements, etc. The completed model will be stored on disk under the indicated file name.
The program will then look at the coordinates specified for the section panels and will construct a vertical profile of each to illustrate the data values, using the selected color scheme. The panels will then be appended together to create the multi-panel section. Logs and other diagram layers will be appended if requested. The completed diagram will be displayed in a RockPlot2D tab in the Options window, if requested.
- You can adjust any of the settings in the Main Options tab and then click the Continue button again to regenerate the section.
! * If the I-Data model looks OK and you just need to adjust one of the diagram settings, you don't need to keep re-interpolating the model. Choose Use Existing Model and browse for the .RwMod file to be used for the section.
- View / save / manipulate / print / export the diagram in the RockPlot2D window.
- Use the Stretch button
in RockPlot to fill the window with the section. This is helpful if the diagram is long and shallow.
- If the section looks better with a vertical exaggeration greater than or less than 1, you can pre-define this in the Options tab, which will generate better-looking axis annotations.
Back to I-Data Menu Summary

RockWare home page